Skip to content

Upgrade Python, Node.JS and GitHub Actions dependencies - #366

Merged
benoit74 merged 1 commit into
mainfrom
benoit74/upgrade-dependencies
Oct 29, 2026
Merged

benoit74 merged 1 commit into
mainfrom
benoit74/upgrade-dependencies

Conversation

@benoit74

Copy link
Copy Markdown
Collaborator

Changes:

  • Python dependencies: raise upper bounds to allow pymupdf 2 (includes fix for CVE-2026-82035, in its CLI only), pillow 13, beartype 0.23, urllib3 2.8 and xxhash 4 (its breaking changes do not affect our usage: bytes input, positional arguments only)
  • QA / test / docs tooling: ruff 0.17.3, pyright 1.1.414, pytest 9.2.0, pytest-mock 3.17.0, coverage 7.15.2 → 7.17.0, mkdocs-material 9.8.0, mkdocstrings 1.0.8, pymdown-extensions 12.3 (breaking changes only concern extensions we do not use), ipython 9.17.1, pre-commit 4.7.0
  • pygments upgraded to 2.21.0, the comment about mkdocs build fails in HtmlFormatter with 'NoneType' object has no attribute 'replace' pygments/pygments#3076 has been removed since this issue is now fixed
  • ruff 0.17 now enforces the dt alias for datetime imports (ICN001): fixed the 4 occurrences instead of ignoring the rule
  • Node.JS dev dependencies upgraded (rollup, eslint, prettier, ava, @rollup/plugin-terser) as well as yarn 4.18.1; rollup is upgraded to 4.65.1 only since 4.66.0 is not yet allowed by the yarn minimum package age gate (24h)
  • Removed unused babel-eslint (deprecated for long) and eslint-config-prettier JS dev dependencies
  • GitHub Actions upgraded to latest major versions (checkout, setup-python, setup-node, codecov-action v7)
  • Exclude .hatch and site folders from pyright, since they were scanned when present locally

Python 3.15 is not targeted yet since libzim and hatch-openzim do not support it yet.

colorthief deprecation warning with Pillow 14 is tracked in #365.

- Allow pymupdf 2, pillow 13, beartype 0.23, urllib3 2.8 and xxhash 4
- Upgrade QA, test and docs tooling; unpin pygments now that
  pygments/pygments#3076 is fixed
- Use dt alias for datetime imports, as required by ruff 0.17 (ICN001)
- Upgrade Node.JS dev dependencies and yarn, remove unused babel-eslint
  and eslint-config-prettier
- Upgrade GitHub Actions to latest major versions
- Exclude .hatch and site folders from pyright
@codecov

codecov Bot commented Oct 29, 2026

Copy link
Copy Markdown

Codecov Report

✅ All modified and coverable lines are covered by tests.
✅ Project coverage is 100.00%. Comparing base (3f02d5b) to head (2449e65).

Additional details and impacted files
@@            Coverage Diff            @@
##              main      #366   +/-   ##
=========================================
  Coverage   100.00%   100.00%           
=========================================
  Files           42        42           
  Lines         2863      2863           
  Branches       430       430           
=========================================
  Hits          2863      2863           

☔ View full report in Codecov by Harness.
📢 Have feedback on the report? Share it here.

🚀 New features to boost your workflow:
  • ❄️ Test Analytics: Detect flaky tests, report on failures, and find test suite problems.
  • 📦 JS Bundle Analysis: Save yourself from yourself by tracking and limiting bundle sizes in JS merges.

@benoit74 benoit74 self-assigned this Oct 29, 2026
@benoit74 benoit74 added this to the 5.5.0 milestone Oct 29, 2026
@benoit74
benoit74 merged commit 539f9fa into main Oct 29, 2026
10 checks passed
@benoit74
benoit74 deleted the benoit74/upgrade-dependencies branch October 29, 2026 08:41
Sign up for free to join this conversation on GitHub. Already have an account? Sign in to comment

Labels

None yet

Projects

None yet

Development

Successfully merging this pull request may close these issues.

1 participant