Skip to content
Navigation Menu
Sign in
Appearance settings
Platform
AI CODE CREATION
GitHub Copilot
Write better code with AI
GitHub Copilot app
Direct agents from issue to merge
MCP Registry
Integrate external tools
DEVELOPER WORKFLOWS
Actions
Automate any workflow
Codespaces
Instant dev environments
Issues
Plan and track work
Code Review
Manage code changes
Code Quality
Enforce quality at merge
APPLICATION SECURITY
GitHub Advanced Security
Find and fix vulnerabilities
Code security
Secure your code as you build
Secret protection
Stop leaks before they start
EXPLORE
Why GitHub
Documentation
Blog
Changelog
Marketplace
View all features
Solutions
BY COMPANY SIZE
Enterprises
Small and medium teams
Startups
Nonprofits
BY USE CASE
App Modernization
DevSecOps
DevOps
CI/CD
View all use cases
BY INDUSTRY
Healthcare
Financial services
Manufacturing
Government
See all industries
View all solutions
Resources
EXPLORE BY TOPIC
AI
Software Development
DevOps
Security
View all topics
EXPLORE BY TYPE
Customer stories
Events & webinars
Ebooks & reports
Business insights
GitHub Skills
SUPPORT & SERVICES
Documentation
Customer support
Community forum
Trust center
Partners
View all resources
Open Source
COMMUNITY
GitHub Sponsors
Fund open source developers
PROGRAMS
Security Lab
Maintainer Community
GitHub Stars
Archive Program
REPOSITORIES
Topics
Trending
Collections
Enterprise
ENTERPRISE SOLUTIONS
Enterprise platform
AI-powered developer platform
AVAILABLE ADD-ONS
GitHub Advanced Security
Enterprise-grade security features
Copilot for Business
Enterprise-grade AI features
Premium Support
Enterprise-grade 24/7 support
Pricing
Search
/
Sign in
Sign up
Appearance settings
You signed in with another tab or window.
Reload
to refresh your session.
You signed out in another tab or window.
Reload
to refresh your session.
You switched accounts on another tab or window.
Reload
to refresh your session.
Dismiss alert
{{ message }}
mozilla
neqo
Repository navigation
Code
Issues
121
(121)
Pull requests
128
(128)
Actions
Security and quality
8
(8)
Insights
More
items
All pull requests
Labels
39
(39)
Milestones
1
(1)
New pull request
Search pull requests
is
:
pr
state
:
open
is:pr state:open
Clear filter
Search
Pull requests
Open
128
(128)
Closed
3,188
(3,188)
Author
Label
Projects
Milestones
Reviews
Assignee
Sort by
Newest
descending
Sort…
Sort by Newest descending
More items
Comfortable display density
Compact display density
test(transport): share a helper for client version information failures
#4206
·
larseggert
opened
Oct 23, 2026
Collaborator
·
5/5
·
·
3
refactor: use named error and alert constants
#4205
·
larseggert
opened
Oct 23, 2026
Collaborator
·
4/5
·
·
3
fix(transport): count failed decryptions against the AEAD integrity limit
#4204
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
7
test: use named error codes and add connect_fail_at
#4203
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
7
test(transport): reuse the rewrite_initial and vn_to_client helpers
#4202
·
larseggert
opened
Oct 23, 2026
Collaborator
·
3/5
·
·
6
fix(transport): reject TLS KeyUpdate messages in CRYPTO frames
#4201
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
6
fix(transport): wait three PTOs after a confirmed key update
#4200
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
6
test(http3): cover reliable reset of the control stream
#4199
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
6
fix(qpack): close with H3_CLOSED_CRITICAL_STREAM on QPACK stream reliable reset
#4198
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
7
docs(qpack): drop stale spec attribution for the 2^30 table size limit
#4196
·
larseggert
opened
Oct 23, 2026
Collaborator
·
2/2
·
·
6
fix(transport): follow RFC 9368 and RFC 9369 version rules after a compatible upgrade
#4194
·
larseggert
opened
Oct 23, 2026
Collaborator
·
2/2
·
·
7
fix(transport): stop processing input once the connection is closed
#4192
·
larseggert
opened
Oct 23, 2026
Collaborator
·
2/2
·
·
6
fix(transport): close with PROTOCOL_VIOLATION on ACK of unsent packet
#4191
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
5
fix(transport): ignore a certificate verdict when TLS is not awaiting one
#4190
·
larseggert
opened
Oct 23, 2026
Collaborator
·
1/2
·
·
6
fix(transport): lower the reliable size with RESET_STREAM on STOP_SENDING
#4189
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
7
fix(transport): add missing RFC 9368 version negotiation checks
#4187
·
larseggert
opened
Oct 23, 2026
Collaborator
·
2/5
·
·
6
fix(transport): use the RFC-required codes for missing transport parameters
#4186
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
6
fix(http3): handle HTTP/3 datagrams per RFC 9297 quarter stream id rules
#4185
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
10
fix(transport): skip the send-stream walk on MAX_DATA when no stream waits for credit
#4184
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
8
fix(transport): send TRANSPORT_PARAMETER_ERROR and VERSION_NEGOTIATION_ERROR for bad transport parameters
#4183
·
larseggert
opened
Oct 23, 2026
Collaborator
·
1/5
·
·
7
fix(http3): bound connect-udp datagram events per control stream read
#4182
·
larseggert
opened
Oct 23, 2026
Collaborator
·
·
6
fix(transport): close with KEY_UPDATE_ERROR on old keys after newer keys
#4181
·
larseggert
opened
Oct 22, 2026
Collaborator
·
·
10
fix(http3): limit total size of interim responses per message
#4180
·
larseggert
opened
Oct 22, 2026
Collaborator
·
·
9
docs(http3): note WebTransport error code mapping on stream reset and stop_sending
#4179
·
larseggert
opened
Oct 22, 2026
Collaborator
·
·
7
fix(http3): don't parse extended CONNECT stream data after a refused response
#4178
·
larseggert
opened
Oct 22, 2026
Collaborator
·
·
6
Previous
1
2
3
4
5
6
Next
You can’t perform that action at this time.