Repository navigation
Conversation
There was a problem hiding this comment.
Code Review
This pull request upgrades the PHP runtime and version constraints to PHP 8.3 (and PHP >= 8.2 in composer.json files) across various App Engine flexible/standard environments, Cloud SQL, Cloud Functions, and Cloud Run configurations. Feedback highlights critical compatibility issues: Drupal 8 does not support PHP 8.2 or 8.3, meaning the Drupal 8 sample should be upgraded to Drupal 10 or removed. Additionally, Laravel 9 does not officially support PHP 8.3, so the PHP version constraint in run/laravel/composer.json should be restricted to ~8.2.0 or the Laravel framework should be upgraded to version 10.
| operating_system: ubuntu22 | ||
| runtime_version: 8.3 |
There was a problem hiding this comment.
Drupal 8 reached End of Life (EOL) in November 2021 and does not support PHP 8.2 or PHP 8.3 (it only supports up to PHP 7.4/8.0). Running Drupal 8 on PHP 8.3 will result in numerous fatal errors and compatibility issues. Since PHP 8.1 and earlier are EOL, the Drupal 8 sample should be upgraded to Drupal 10 to support PHP 8.2+, or removed if it is no longer maintained.
| "license": "MIT", | ||
| "require": { | ||
| "php": "^8.1", | ||
| "php": "^8.2", |
There was a problem hiding this comment.
The project uses Laravel 9 ("laravel/framework": "^9.19"), which does not officially support PHP 8.3. Since "php": "^8.2" allows PHP 8.3, this can lead to runtime compatibility issues when deployed to environments running PHP 8.3. Consider upgrading the Laravel framework dependency to ^10.0 (which officially supports PHP 8.3) or restricting the PHP version constraint to ~8.2.0 if upgrading is not feasible.
| "php": "^8.2", | |
| "php": "~8.2.0", |
There was a problem hiding this comment.
Updated (and removed some Laravel samples).
7d4e650 to
2536243
Compare
2536243 to
6f792ac
Compare
Summary
PHP 8.1 and earlier runtimes have reached End of Support and do not receive upstream security fixes for CVE-2026-109618 and CVE-2026-109619.
This PR updates the active sample runtime configurations and Composer platform constraints across the repository off legacy PHP
< 8.2runtimes (while deprecated/unreferencedappengine/flexible/drupal8,appengine/flexible/laravel, andrun/laravelsamples are removed separately in #2341):app.yamls (13 files + README): Updateruntime: php81toruntime: php83acrossappengine/standard/*andpubsub/app/app.yaml.app.yamls (12 files): Addoperating_system: ubuntu22andruntime_version: 8.3underruntime_config:acrossappengine/flexible/*,cloud_sql/{mysql,postgres}/pdo/app.flex.yaml, andendpoints/getting-started/app.yaml(matching the existing Flex samples updated in chore: Update some PHP GAE Flex samples to use newer runtimes #2019).composer.jsonPHP version constraints (9 files): Update minimum PHP version requirements from^7.1.3/>= 7.2/>= 8.1/^8.1to>= 8.2/^8.2intesting/composer.json,functions/*,cloud_sql/*/pdo, andappengine/standard/symfony-framework.